What’s Vulnerable › Vulnerabilities
CVE-2021-21263: Query Binding Exploitation in Laravel
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-19 · updated 2026-06-17
- Weakness: CWE-74
Description
Laravel is a web application framework. Versions of Laravel before 6.20.11, 7.30.2 and 8.22.1 contain a query binding exploitation. This same exploit applies to the illuminate/database package which is used by Laravel. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the query to return unexpected results.
Affected products
- Laravel Framework: from 6.0.0 before 6.20.11; from 7.0.0 before 7.30.2; from 8.0.0 before 8.22.1 — fixed in 6.20.11, 7.30.2, 8.22.1
How to fix
Upgrade to a fixed version: Laravel Framework 6.20.11, 7.30.2, 8.22.1. Check the vendor advisory for mitigations.
References
- https://blog.laravel.com/security-laravel-62011-7302-8221-released
- https://github.com/laravel/framework/pull/35865
- https://github.com/laravel/framework/security/advisories/GHSA-3p32-j457-pg5x
- https://packagist.org/packages/illuminate/database
- https://packagist.org/packages/laravel/framework
- https://blog.laravel.com/security-laravel-62011-7302-8221-released
- https://github.com/laravel/framework/pull/35865
- https://github.com/laravel/framework/security/advisories/GHSA-3p32-j457-pg5x
- https://packagist.org/packages/illuminate/database
- https://packagist.org/packages/laravel/framework
Get alerted when CVE-2021-21263 or the next vulnerability affects your stack