What’s Vulnerable › Vulnerabilities
CVE-2021-21276: Privilege escalation in Polr
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-01 · updated 2026-06-17
- Weakness: CWE-863
Description
Polr is an open source URL shortener. in Polr before version 2.3.0, a vulnerability in the setup process allows attackers to gain admin access to site instances, even if they do not possess an existing account. This vulnerability exists regardless of users' settings. If an attacker crafts a request with specific cookie headers to the /setup/finish endpoint, they may be able to obtain admin privileges on the instance. This is caused by a loose comparison (==) in SetupController that is susceptible to attack. The project has been patched to ensure that a strict comparison (===) is used to verify the setup key, and that /setup/finish verifies that no users table exists before performing any migrations or provisioning any new accounts. This is fixed in version 2.3.0. Users can patch this vulnerability without upgrading by adding abort(404) to the very first line of finishSetup in SetupController.php.
Affected products
- cydrobolt polr: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: cydrobolt polr 2.3.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171743/POLR-URL-2.3.0-Shortener-Admin-Takeover.html
- https://github.com/cydrobolt/polr/commit/b1981709908caf6069b4a29dad3b6739c322c675
- https://github.com/cydrobolt/polr/releases/tag/2.3.0
- https://github.com/cydrobolt/polr/security/advisories/GHSA-vg6w-8w9v-xxqc
- http://packetstormsecurity.com/files/171743/POLR-URL-2.3.0-Shortener-Admin-Takeover.html
- https://github.com/cydrobolt/polr/commit/b1981709908caf6069b4a29dad3b6739c322c675
- https://github.com/cydrobolt/polr/releases/tag/2.3.0
- https://github.com/cydrobolt/polr/security/advisories/GHSA-vg6w-8w9v-xxqc
Get alerted when CVE-2021-21276 or the next vulnerability affects your stack