What’s Vulnerable › Vulnerabilities
CVE-2021-21277: Angular Expressions - Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-01 · updated 2026-06-17
- Weakness: CWE-74
Description
angular-expressions is "angular's nicest part extracted as a standalone module for the browser and node". In angular-expressions before version 1.1.2 there is a vulnerability which allows Remote Code Execution if you call "expressions.compile(userControlledInput)" where "userControlledInput" is text that comes from user input. The security of the package could be bypassed by using a more complex payload, using a ".constructor.constructor" technique. In terms of impact: If running angular-expressions in the browser, an attacker could run any browser script when the application code calls expressions.compile(userControlledInput). If running angular-expressions on the server, an attacker could run any Javascript expression, thus gaining Remote Code Execution. This is fixed in version 1.1.2 of angular-expressions A temporary workaround might be either to disable user-controlled input that will be fed into angular-expressions in your application or allow only following characters in the userControlledInput.
Affected products
- peerigon angular-expressions: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: peerigon angular-expressions 1.1.2. Check the vendor advisory for mitigations.
References
- http://blog.angularjs.org/2016/09/angular-16-expression-sandbox-removal.html
- https://github.com/peerigon/angular-expressions/commit/07edb62902b1f6127b3dcc013da61c6316dd0bf1
- https://github.com/peerigon/angular-expressions/security/advisories/GHSA-j6px-jwvv-vpwq
- https://www.npmjs.com/package/angular-expressions
- http://blog.angularjs.org/2016/09/angular-16-expression-sandbox-removal.html
- https://github.com/peerigon/angular-expressions/commit/07edb62902b1f6127b3dcc013da61c6316dd0bf1
- https://github.com/peerigon/angular-expressions/security/advisories/GHSA-j6px-jwvv-vpwq
- https://www.npmjs.com/package/angular-expressions
Get alerted when CVE-2021-21277 or the next vulnerability affects your stack