What’s Vulnerable › Vulnerabilities
CVE-2021-21280: Out-of-bounds write when processing 6LoWPAN extension headers
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-18 · updated 2026-06-17
- Weakness: CWE-787
Description
Contiki-NG is an open-source, cross-platform operating system for internet of things devices. It is possible to cause an out-of-bounds write in versions of Contiki-NG prior to 4.6 when transmitting a 6LoWPAN packet with a chain of extension headers. Unfortunately, the written header is not checked to be within the available space, thereby making it possible to write outside the buffer. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.
Affected products
- contiki-ng: before 4.6 — fixed in 4.6
How to fix
Upgrade to a fixed version: contiki-ng 4.6. Check the vendor advisory for mitigations.
References
- https://github.com/contiki-ng/contiki-ng/pull/1409
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-r768-hrhf-v592
- https://github.com/contiki-ng/contiki-ng/pull/1409
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-r768-hrhf-v592
Get alerted when CVE-2021-21280 or the next vulnerability affects your stack