What’s Vulnerable › Vulnerabilities
CVE-2021-21281: Buffer overflow due to unvalidated TCP data offset
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-18 · updated 2026-06-17
- Weakness: CWE-120
Description
Contiki-NG is an open-source, cross-platform operating system for internet of things devices. A buffer overflow vulnerability exists in Contiki-NG versions prior to 4.6. After establishing a TCP socket using the tcp-socket library, it is possible for the remote end to send a packet with a data offset that is unvalidated. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.
Affected products
- contiki-ng: before 4.6 — fixed in 4.6
How to fix
Upgrade to a fixed version: contiki-ng 4.6. Check the vendor advisory for mitigations.
References
- https://github.com/contiki-ng/contiki-ng/pull/1366
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-mc42-fqfr-h9fp
- https://github.com/contiki-ng/contiki-ng/pull/1366
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-mc42-fqfr-h9fp
Get alerted when CVE-2021-21281 or the next vulnerability affects your stack