What’s Vulnerable › Vulnerabilities
CVE-2021-21296: Denial-of-service in Fleet
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-10 · updated 2026-10-06
- Weakness: CWE-400
Description
Fleet is an open source osquery manager. In Fleet before version 3.7.0 a malicious actor with a valid node key can send a badly formatted request that causes the Fleet server to exit, resulting in denial of service. This is possible only while a live query is currently ongoing. We believe the impact of this vulnerability to be low given the requirement that the actor has a valid node key. There is no information disclosure, privilege escalation, or code execution. The issue is fixed in Fleet 3.7.0.
Affected products
- fleetdm fleet: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: fleetdm fleet 3.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/fleetdm/fleet/commit/f68f4238e83b45b2164e4ed05df14af0f06eaf40
- https://github.com/fleetdm/fleet/security/advisories/GHSA-xwh8-9p3f-3x45
- https://www.npmjs.com/package/fleetctl
- https://github.com/fleetdm/fleet/commit/f68f4238e83b45b2164e4ed05df14af0f06eaf40
- https://github.com/fleetdm/fleet/security/advisories/GHSA-xwh8-9p3f-3x45
- https://www.npmjs.com/package/fleetctl
Get alerted when CVE-2021-21296 or the next vulnerability affects your stack