What’s Vulnerable › Vulnerabilities
CVE-2021-21304: Prototype Pollution in Dynamoose
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-08 · updated 2026-06-17
- Weakness: CWE-915
Description
Dynamoose is an open-source modeling tool for Amazon's DynamoDB. In Dynamoose from version 2.0.0 and before version 2.7.0 there was a prototype pollution vulnerability in the internal utility method "lib/utils/object/set.ts". This method is used throughout the codebase for various operations throughout Dynamoose. We have not seen any evidence of this vulnerability being exploited. There is no evidence this vulnerability impacts versions 1.x.x since the vulnerable method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions. Version 2.7.0 includes a patch for this vulnerability.
Affected products
- dynamoose: from 2.0.0 before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: dynamoose 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/dynamoose/dynamoose/commit/324c62b4709204955931a187362f8999805b1d8e
- https://github.com/dynamoose/dynamoose/releases/tag/v2.7.0
- https://github.com/dynamoose/dynamoose/security/advisories/GHSA-rrqm-p222-8ph2
- https://www.npmjs.com/package/dynamoose
- https://github.com/dynamoose/dynamoose/commit/324c62b4709204955931a187362f8999805b1d8e
- https://github.com/dynamoose/dynamoose/releases/tag/v2.7.0
- https://github.com/dynamoose/dynamoose/security/advisories/GHSA-rrqm-p222-8ph2
- https://www.npmjs.com/package/dynamoose
Get alerted when CVE-2021-21304 or the next vulnerability affects your stack