What’s Vulnerable › Vulnerabilities
CVE-2021-21311: Adminer Server-Side Request Forgery Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-09-29
- EPSS: 98.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-11 · updated 2026-06-17
- Weakness: CWE-918
Description
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
Affected products
- vrana adminer: from 4.0.0 before 4.7.9 — fixed in 4.7.9
- Debian Linux: 9.0
How to fix
Upgrade to a fixed version: vrana adminer 4.7.9. Check the vendor advisory for mitigations.
References
- https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351
- https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf
- https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6
- https://lists.debian.org/debian-lts-announce/2021/03/msg00002.html
- https://packagist.org/packages/vrana/adminer
- https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351
- https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf
- https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6
- https://lists.debian.org/debian-lts-announce/2021/03/msg00002.html
- https://packagist.org/packages/vrana/adminer
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-21311
Get alerted when CVE-2021-21311 or the next vulnerability affects your stack