What’s Vulnerable › Vulnerabilities
CVE-2021-21313: XSS on tabs
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-74
Description
GLPI is open source software which stands for Gestionnaire Libre de Parc Informatique and it is a Free Asset and IT Management Software package. In GLPI before verison 9.5.4, there is a vulnerability in the /ajax/common.tabs.php endpoint, indeed, at least two parameters _target and id are not properly sanitized. Here are two payloads (due to two different exploitations depending on which parameter you act) to exploit the vulnerability:/ajax/common.tabs.php?_target=javascript:alert(document.cookie)&_itemtype=DisplayPreference&_glpi_tab=DisplayPreference$2&id=258&displaytype=Ticket (Payload triggered if you click on the button). /ajax/common.tabs.php?_target=/front/ticket.form.php&_itemtype=Ticket&_glpi_tab=Ticket$1&id=(){};(function%20(){alert(document.cookie);})();function%20a&#.
Affected products
- glpi-project glpi: before 9.5.4 — fixed in 9.5.4
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-h4hj-mrpg-xfgx
- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-h4hj-mrpg-xfgx
Get alerted when CVE-2021-21313 or the next vulnerability affects your stack