What’s Vulnerable › Vulnerabilities
CVE-2021-21314: XSS injection on ticket update
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is open source software which stands for Gestionnaire Libre de Parc Informatique and it is a Free Asset and IT Management Software package. In GLPI before verison 9.5.4, there is an XSS vulnerability involving a logged in user while updating a ticket.
Affected products
- glpi-project glpi: before 9.5.4 — fixed in 9.5.4
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-2w7j-xgj7-3xgg
- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-2w7j-xgj7-3xgg
Get alerted when CVE-2021-21314 or the next vulnerability affects your stack