What’s Vulnerable › Vulnerabilities
CVE-2021-21322: Prefix escape
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-02 · updated 2026-06-17
- Weakness: CWE-20
Description
fastify-http-proxy is an npm package which is a fastify plugin for proxying your http requests to another server, with hooks. By crafting a specific URL, it is possible to escape the prefix of the proxied backend service. If the base url of the proxied server is `/pub/`, a user expect that accessing `/priv` on the target service would not be possible. In affected versions, it is possible. This is fixed in version 4.3.1.
Affected products
- fastify-http-proxy: before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: fastify-http-proxy 4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/fastify/fastify-http-proxy/commit/02d9b43c770aa16bc44470edecfaeb7c17985016
- https://github.com/fastify/fastify-http-proxy/security/advisories/GHSA-c4qr-gmr9-v23w
- https://www.npmjs.com/package/fastify-http-proxy
- https://github.com/fastify/fastify-http-proxy/commit/02d9b43c770aa16bc44470edecfaeb7c17985016
- https://github.com/fastify/fastify-http-proxy/security/advisories/GHSA-c4qr-gmr9-v23w
- https://www.npmjs.com/package/fastify-http-proxy
Get alerted when CVE-2021-21322 or the next vulnerability affects your stack