What’s Vulnerable › Vulnerabilities
CVE-2021-21327: Unsafe Reflection in getItemForItemtype()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-08 · updated 2026-06-17
- Weakness: CWE-862
Description
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated user can remotely instantiate object of any class existing in the GLPI environment that can be used to carry out malicious attacks, or to start a “POP chain”. As an example of direct impact, this vulnerability affects integrity of the GLPI core platform and third-party plugins runtime misusing classes which implement some sensitive operations in their constructors or destructors. This is fixed in version 9.5.4.
Affected products
- glpi-project glpi: before 9.5.4 — fixed in 9.5.4
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/161680/GLPI-9.5.3-Unsafe-Reflection.html
- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-qmw7-w2m4-rjwp
- http://packetstormsecurity.com/files/161680/GLPI-9.5.3-Unsafe-Reflection.html
- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-qmw7-w2m4-rjwp
Get alerted when CVE-2021-21327 or the next vulnerability affects your stack