What’s Vulnerable › Vulnerabilities
CVE-2021-21345: XStream is vulnerable to a Remote Command Execution attack
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 72.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-23 · updated 2026-10-07
- Weakness: CWE-94
Description
XStream is a Java library to serialize objects to XML and back again. In XStream before version 1.4.16, there is a vulnerability which may allow a remote attacker who has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16.
Affected products
- Apache ActiveMQ: before 5.15.14; 5.16.0, 5.16.1 — fixed in 5.15.14
- Apache Software Foundation Apache JMeter: before 5.5 — fixed in 5.5
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 33, 34, 35
- OnCommand Insight: all versions
- Oracle Banking Enterprise Default Management: 2.10.0, 2.12.0
- Oracle Banking Platform: 2.4.0, 2.7.1, 2.9.0, 2.12.0
- Oracle Corporation Banking Virtual Account Management: 14.2.0, 14.3.0, 14.5.0
- Oracle Business Activity Monitoring: 11.1.1.9.0, 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle Communications BRM - Elastic Charging Engine: 12.0.0.3.0
- Oracle Corporation Communications Policy Management: 12.5.0
- Oracle Corporation Oracle Communications Unified Inventory Management: 7.3.2, 7.3.4, 7.3.5, 7.4.0, 7.4.1
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.58, 8.59
- Oracle Corporation Retail Xstore Point of Service: 16.0.6, 17.0.4, 18.0.3, 19.0.2
- Oracle Corporation Oracle WebCenter Portal: 11.1.1.9.0, 12.2.1.3.0, 12.2.1.4.0
- x-stream xstream: before 1.4.16 — fixed in 1.4.16
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.15.14; Apache Software Foundation Apache JMeter 5.5; x-stream xstream 1.4.16. Check the vendor advisory for mitigations.
References
- http://x-stream.github.io/changes.html#1.4.16
- https://github.com/x-stream/xstream/security/advisories/GHSA-hwpc-8xqv-jvj4
- https://lists.apache.org/thread.html/r8244fd0831db894d5e89911ded9c72196d395a90ae655414d23ed0dd%40%3Cusers.activemq.apache.org%3E
- https://lists.apache.org/thread.html/r9ac71b047767205aa22e3a08cb33f3e0586de6b2fac48b425c6e16b0%40%3Cdev.jmeter.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2021/04/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/22KVR6B5IZP3BGQ3HPWIO2FWWCKT3DHP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PVPHZA7VW2RRSDCOIPP2W6O5ND254TU7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QGXIU3YDPG6OGTDHMBLAFN7BPBERXREB/
- https://security.netapp.com/advisory/ntap-20210430-0002/
- https://www.debian.org/security/2021/dsa-5004
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://www.oracle.com/security-alerts/cpuApr2021.html
Get alerted when CVE-2021-21345 or the next vulnerability affects your stack