What’s Vulnerable › Vulnerabilities
CVE-2021-21353: Remote code execution in pug
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-74
Description
Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. This is fixed in version 3.0.1. This advisory applies to multiple pug packages including "pug", "pug-code-gen". pug-code-gen has a backported fix at version 2.0.3. This advisory is not exploitable if there is no way for un-trusted input to be passed to pug as the `pretty` option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.
Affected products
- pugjs pug: before 3.0.1 — fixed in 3.0.1
- pugjs Pug-Code-Gen: before 2.0.3; from 3.0.0 before 3.0.2 — fixed in 2.0.3, 3.0.2
How to fix
Upgrade to a fixed version: pugjs pug 3.0.1; pugjs Pug-Code-Gen 2.0.3, 3.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/pugjs/pug/commit/991e78f7c4220b2f8da042877c6f0ef5a4683be0
- https://github.com/pugjs/pug/issues/3312
- https://github.com/pugjs/pug/pull/3314
- https://github.com/pugjs/pug/releases/tag/pug%403.0.1
- https://github.com/pugjs/pug/security/advisories/GHSA-p493-635q-r6gr
- https://www.npmjs.com/package/pug
- https://www.npmjs.com/package/pug-code-gen
- https://github.com/pugjs/pug/commit/991e78f7c4220b2f8da042877c6f0ef5a4683be0
- https://github.com/pugjs/pug/issues/3312
- https://github.com/pugjs/pug/pull/3314
- https://github.com/pugjs/pug/releases/tag/pug%403.0.1
- https://github.com/pugjs/pug/security/advisories/GHSA-p493-635q-r6gr
Get alerted when CVE-2021-21353 or the next vulnerability affects your stack