What’s Vulnerable › Vulnerabilities
CVE-2021-21361: Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-09 · updated 2026-06-17
- Weakness: CWE-532
Description
The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed in version 3.0.0.
Affected products
- Vagrant Project Vagrant: before 0.6; from 2.0 before 3.0.0 — fixed in 0.6, 3.0.0
How to fix
Upgrade to a fixed version: Vagrant Project Vagrant 0.6, 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/JLLeitschuh/security-research/security/advisories/GHSA-jpcm-4485-69p7
- https://github.com/bmuschko/gradle-vagrant-plugin/blob/292129f9343d00d391543fae06239e9b0f33db73/src/main/groovy/com/bmuschko/gradle/vagrant/process/GDKExternalProcessExecutor.groovy#L42-L44
- https://github.com/bmuschko/gradle-vagrant-plugin/issues/19
- https://github.com/bmuschko/gradle-vagrant-plugin/pull/20
- https://github.com/JLLeitschuh/security-research/security/advisories/GHSA-jpcm-4485-69p7
- https://github.com/bmuschko/gradle-vagrant-plugin/blob/292129f9343d00d391543fae06239e9b0f33db73/src/main/groovy/com/bmuschko/gradle/vagrant/process/GDKExternalProcessExecutor.groovy#L42-L44
- https://github.com/bmuschko/gradle-vagrant-plugin/issues/19
- https://github.com/bmuschko/gradle-vagrant-plugin/pull/20
Get alerted when CVE-2021-21361 or the next vulnerability affects your stack