What’s Vulnerable › Vulnerabilities
CVE-2021-21370: Cross-Site Scripting in Content Preview (CType menu)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-23 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 it has been discovered that content elements of type _menu_ are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.
Affected products
- typo3: from 7.0.0 before 7.6.51; from 8.0.0 before 8.7.40; from 9.0.0 before 9.5.25; from 10.0.0 before 10.4.14; from 11.0.0 before 11.1.1 — fixed in 10.4.14, 11.1.1, 7.6.51, 8.7.40, 9.5.25
How to fix
Upgrade to a fixed version: typo3 10.4.14, 11.1.1, 7.6.51, 8.7.40. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-x7hc-x7fm-f7qh
- https://packagist.org/packages/typo3/cms-backend
- https://typo3.org/security/advisory/typo3-core-sa-2021-008
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-x7hc-x7fm-f7qh
- https://packagist.org/packages/typo3/cms-backend
- https://typo3.org/security/advisory/typo3-core-sa-2021-008
Get alerted when CVE-2021-21370 or the next vulnerability affects your stack