What’s Vulnerable › Vulnerabilities
CVE-2021-21374: Nimble fails to validate certificates due to insecure httpClient defaults
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-26 · updated 2026-06-17
- Weakness: CWE-348
Description
Nimble is a package manager for the Nim programming language. In Nim release versions before versions 1.2.10 and 1.4.4, "nimble refresh" fetches a list of Nimble packages over HTTPS without full verification of the SSL/TLS certificate due to the default setting of httpClient. An attacker able to perform MitM can deliver a modified package list containing malicious software packages. If the packages are installed and used the attack escalates to untrusted code execution.
Affected products
- nim-lang Nim: before 1.2.10; from 1.4.0 before 1.4.4 — fixed in 1.2.10, 1.4.4
How to fix
Upgrade to a fixed version: nim-lang Nim 1.2.10, 1.4.4. Check the vendor advisory for mitigations.
References
- https://consensys.net/diligence/vulnerabilities/nim-insecure-ssl-tls-defaults-remote-code-execution/
- https://github.com/nim-lang/Nim/pull/16940
- https://github.com/nim-lang/nimble/blob/master/changelog.markdown#0130
- https://github.com/nim-lang/security/security/advisories/GHSA-c2wm-v66h-xhxx
- https://consensys.net/diligence/vulnerabilities/nim-insecure-ssl-tls-defaults-remote-code-execution/
- https://github.com/nim-lang/Nim/pull/16940
- https://github.com/nim-lang/nimble/blob/master/changelog.markdown#0130
- https://github.com/nim-lang/security/security/advisories/GHSA-c2wm-v66h-xhxx
Get alerted when CVE-2021-21374 or the next vulnerability affects your stack