What’s Vulnerable › Vulnerabilities
CVE-2021-21389: BuddyPress privilege escalation via REST API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-26 · updated 2026-06-17
- Weakness: CWE-863
Description
BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.
Affected products
- BuddyPress: from 5.0.0 before 7.2.1 — fixed in 7.2.1
How to fix
Upgrade to a fixed version: BuddyPress 7.2.1. Check the vendor advisory for mitigations.
References
- https://buddypress.org/2021/03/buddypress-7-2-1-security-release/
- https://codex.buddypress.org/releases/version-7-2-1/
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3
- https://buddypress.org/2021/03/buddypress-7-2-1-security-release/
- https://codex.buddypress.org/releases/version-7-2-1/
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3
Get alerted when CVE-2021-21389 or the next vulnerability affects your stack