What’s Vulnerable › Vulnerabilities
CVE-2021-21391: Regular expression Denial of Service in multiple packages
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-29 · updated 2026-06-17
- Weakness: CWE-400
Description
CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.
Affected products
- Ckeditor5-Engine: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-Font: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-Image: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-List: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-Markdown-Gfm: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-Media-Embed: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-Paste-From-Office: before 27.0.0 — fixed in 27.0.0
- Ckeditor5-Widget: before 27.0.0 — fixed in 27.0.0
How to fix
Upgrade to a fixed version: Ckeditor5-Engine 27.0.0; Ckeditor5-Font 27.0.0; Ckeditor5-Image 27.0.0; Ckeditor5-List 27.0.0; Ckeditor5-Markdown-Gfm 27.0.0; Ckeditor5-Media-Embed 27.0.0; Ckeditor5-Paste-From-Office 27.0.0; Ckeditor5-Widget 27.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-3rh3-wfr4-76mj
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-engine
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-font
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-image
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-list
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-markdown-gfm
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-media-embed
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-paste-from-office
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-widget
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-3rh3-wfr4-76mj
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-engine
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-font
Get alerted when CVE-2021-21391 or the next vulnerability affects your stack