What’s Vulnerable › Vulnerabilities
CVE-2021-21394: Denial of service (via resource exhaustion) due to improper input validation on third-party identifier endpoints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.28.0 Synapse is missing input validation of some parameters on the endpoints used to confirm third-party identifiers could cause excessive use of disk space and memory leading to resource exhaustion. Note that the groups feature is not part of the Matrix specification and the chosen maximum lengths are arbitrary. Not all clients might abide by them. Refer to referenced GitHub security advisory for additional details including workarounds.
Affected products
- Fedoraproject Fedora: 34
- matrix-org synapse: from 0.17.0 (excl.) before 1.28.0 — fixed in 1.28.0
How to fix
Upgrade to a fixed version: matrix-org synapse 1.28.0. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/synapse/pull/9321
- https://github.com/matrix-org/synapse/pull/9393
- https://github.com/matrix-org/synapse/security/advisories/GHSA-w9fg-xffh-p362
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNNAJOZNMVMXM6AS7RFFKB4QLUJ4IFEY/
- https://pypi.org/project/matrix-synapse/
- https://github.com/matrix-org/synapse/pull/9321
- https://github.com/matrix-org/synapse/pull/9393
- https://github.com/matrix-org/synapse/security/advisories/GHSA-w9fg-xffh-p362
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNNAJOZNMVMXM6AS7RFFKB4QLUJ4IFEY/
- https://pypi.org/project/matrix-synapse/
Get alerted when CVE-2021-21394 or the next vulnerability affects your stack