What’s Vulnerable › Vulnerabilities
CVE-2021-21395: Magneto-lts vulnerable to Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-352
Description
Magneto LTS (Long Term Support) is a community developed alternative to the Magento CE official releases. Versions prior to 19.4.22 and 20.0.19 are vulnerable to Cross-Site Request Forgery. The password reset form is vulnerable to CSRF between the time the reset password link is clicked and user submits new password. This issue is patched in versions 19.4.22 and 20.0.19. There are no workarounds.
Affected products
- OpenMage magento-lts: before 19.4.22; from 20.0.0 before 20.0.19 — fixed in 19.4.22, 20.0.19
How to fix
Upgrade to a fixed version: OpenMage magento-lts 19.4.22, 20.0.19. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-r3c9-9j5q-pwv4
- https://hackerone.com/reports/1086752
- https://packagist.org/packages/openmage/magento-lts
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-r3c9-9j5q-pwv4
- https://hackerone.com/reports/1086752
- https://packagist.org/packages/openmage/magento-lts
Get alerted when CVE-2021-21395 or the next vulnerability affects your stack