What’s Vulnerable › Vulnerabilities
CVE-2021-21399: Unauthenticated SubSonic backend access in Ampache
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-13 · updated 2026-06-17
- Weakness: CWE-284
Description
Ampache is a web based audio/video streaming application and file manager. Versions prior to 4.4.1 allow unauthenticated access to Ampache using the subsonic API. To successfully make the attack you must use a username that is not part of the site to bypass the auth checks. For more details and workaround guidance see the referenced GitHub security advisory.
Affected products
- ampache: before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: ampache 4.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/ampache/ampache/security/advisories/GHSA-p9pm-j95j-5mjf
- https://github.com/ampache/ampache/security/advisories/GHSA-p9pm-j95j-5mjf
Get alerted when CVE-2021-21399 or the next vulnerability affects your stack