What’s Vulnerable › Vulnerabilities

CVE-2021-21409: Possible request smuggling in HTTP/2 due missing validation of content-length

Description

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.

Affected products

How to fix

Upgrade to a fixed version: netty 4.1.61; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.3; Oracle Nosql Database 21.1.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21409 or the next vulnerability affects your stack