What’s Vulnerable › Vulnerabilities
CVE-2021-21414: Command injection vulnerability in @prisma/sdk in getPackedPackage function
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-29 · updated 2026-06-17
- Weakness: CWE-78
Description
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the `@prisma/sdk` package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the `getPackedPackage` function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
Affected products
- prisma: before 2.20.0 — fixed in 2.20.0
How to fix
Upgrade to a fixed version: prisma 2.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/prisma/prisma/pull/6245
- https://github.com/prisma/prisma/security/advisories/GHSA-pxcc-hj8w-fmm7
- https://security.netapp.com/advisory/ntap-20210618-0003/
- https://github.com/prisma/prisma/pull/6245
- https://github.com/prisma/prisma/security/advisories/GHSA-pxcc-hj8w-fmm7
- https://security.netapp.com/advisory/ntap-20210618-0003/
Get alerted when CVE-2021-21414 or the next vulnerability affects your stack