What’s Vulnerable › Vulnerabilities
CVE-2021-21417: Use after free in fluidsynth
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-29 · updated 2026-06-17
- Weakness: CWE-416
Description
fluidsynth is a software synthesizer based on the SoundFont 2 specifications. A use after free violation was discovered in fluidsynth, that can be triggered when loading an invalid SoundFont file.
Affected products
- Debian Linux: 9.0
- fluidsynth: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: fluidsynth 2.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/FluidSynth/fluidsynth/issues/808
- https://github.com/FluidSynth/fluidsynth/pull/810
- https://github.com/FluidSynth/fluidsynth/security/advisories/GHSA-6fcq-pxhc-jxc9
- https://lists.debian.org/debian-lts-announce/2021/06/msg00027.html
- https://github.com/FluidSynth/fluidsynth/issues/808
- https://github.com/FluidSynth/fluidsynth/pull/810
- https://github.com/FluidSynth/fluidsynth/security/advisories/GHSA-6fcq-pxhc-jxc9
- https://lists.debian.org/debian-lts-announce/2021/06/msg00027.html
Get alerted when CVE-2021-21417 or the next vulnerability affects your stack