What’s Vulnerable › Vulnerabilities
CVE-2021-21420: Vulnerability in Stripe for Visual Studio Code < 1.7.3
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-01 · updated 2026-06-17
- Weakness: CWE-74
Description
vscode-stripe is an extension for Visual Studio Code. A vulnerability in Stripe for Visual Studio Code extension exists when it loads an untrusted source-code repository containing malicious settings. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user. The update addresses the vulnerability by modifying the way the extension validates its settings.
Affected products
- stripe vscode-stripe: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: stripe vscode-stripe 1.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/stripe/vscode-stripe/security/advisories/GHSA-j6x4-4622-8vv3
- https://github.com/stripe/vscode-stripe/security/advisories/GHSA-j6x4-4622-8vv3
Get alerted when CVE-2021-21420 or the next vulnerability affects your stack