What’s Vulnerable › Vulnerabilities
CVE-2021-21424: Prevent user enumeration using Guard or the new Authenticator-based Security
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-13 · updated 2026-06-17
- Weakness: CWE-200
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. The ability to enumerate users was possible without relevant permissions due to different handling depending on whether the user existed or not when attempting to use the switch users functionality. We now ensure that 403s are returned whether the user exists or not if a user cannot switch to a user or if the user does not exist. The patch for this issue is available for branch 3.4.
Affected products
- Fedoraproject Fedora: 33, 34
- symfony: from 2.8.0 before 3.4.48; from 4.0.0 before 4.4.23; from 5.0.0 before 5.2.8 — fixed in 3.4.48, 4.4.23, 5.2.8
How to fix
Upgrade to a fixed version: symfony 3.4.48, 4.4.23, 5.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/2a581d22cc621b33d5464ed65c4bc2057f72f011
- https://github.com/symfony/symfony/security/advisories/GHSA-5pv8-ppvj-4h68
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KENRNLB3FYXYGDWRBH2PDBOZZKOD7VY4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RH7TMM5CHQYBFFGXWRPJDPB3SKCZXI2M/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UC7BND775DVZDQT3RMGD2HVB2PKLJDJW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VRUS2H2SSOQWNLBD35SKIWIDQEMV2PD3/
- https://github.com/symfony/symfony/commit/2a581d22cc621b33d5464ed65c4bc2057f72f011
- https://github.com/symfony/symfony/security/advisories/GHSA-5pv8-ppvj-4h68
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KENRNLB3FYXYGDWRBH2PDBOZZKOD7VY4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RH7TMM5CHQYBFFGXWRPJDPB3SKCZXI2M/
Get alerted when CVE-2021-21424 or the next vulnerability affects your stack