What’s Vulnerable › Vulnerabilities

CVE-2021-2144

Description

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Parser). Supported versions that are affected are 5.7.29 and prior and 8.0.19 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in takeover of MySQL Server. CVSS 3.1 Base Score 7.2 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H).

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.1.42, 10.2.28, 10.3.19, 10.4.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-2144 or the next vulnerability affects your stack