What’s Vulnerable › Vulnerabilities
CVE-2021-21501: ServiceComb ServiceCenter Directory Traversal
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-10 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper configuration will cause ServiceComb ServiceCenter Directory Traversal problem in ServcieCenter 1.x.x versions and fixed in 2.0.0.
Affected products
- Apache Software Foundation Apache ServiceComb Service-Center: from 1.0.0 before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ServiceComb Service-Center 2.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/08/10/3
- https://lists.apache.org/thread.html/r337be65e504eac52a12e89d7de40345e5d335deee9dd7288f7f59b81%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/r337be65e504eac52a12e89d7de40345e5d335deee9dd7288f7f59b81%40%3Cdev.servicecomb.apache.org%3E
- http://www.openwall.com/lists/oss-security/2021/08/10/3
- https://lists.apache.org/thread.html/r337be65e504eac52a12e89d7de40345e5d335deee9dd7288f7f59b81%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/r337be65e504eac52a12e89d7de40345e5d335deee9dd7288f7f59b81%40%3Cdev.servicecomb.apache.org%3E
Get alerted when CVE-2021-21501 or the next vulnerability affects your stack