What’s Vulnerable › Vulnerabilities
CVE-2021-21507
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-261
Description
Dell EMC Networking X-Series firmware versions prior to 3.0.1.8 and Dell EMC PowerEdge VRTX Switch Module firmware versions prior to 2.0.0.82 contain a Weak Password Encryption Vulnerability. A remote unauthenticated attacker could potentially exploit this vulnerability, leading to the disclosure of certain user credentials. The attacker may be able to use the exposed credentials to access the vulnerable system with privileges of the compromised account.
Affected products
- Dell R1-2210 Firmware: before 2.0.0.82 — fixed in 2.0.0.82
- Dell R1-2401 Firmware: before 2.0.0.82 — fixed in 2.0.0.82
- Dell X1008 Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1008P Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1018 Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1018P Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1026 Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1026P Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1052 Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X1052P Firmware: before 3.0.1.8 — fixed in 3.0.1.8
- Dell X4012 Firmware: before 3.0.1.8 — fixed in 3.0.1.8
How to fix
Upgrade to a fixed version: Dell R1-2210 Firmware 2.0.0.82; Dell R1-2401 Firmware 2.0.0.82; Dell X1008 Firmware 3.0.1.8; Dell X1008P Firmware 3.0.1.8; Dell X1018 Firmware 3.0.1.8; Dell X1018P Firmware 3.0.1.8; Dell X1026 Firmware 3.0.1.8; Dell X1026P Firmware 3.0.1.8; Dell X1052 Firmware 3.0.1.8; Dell X1052P Firmware 3.0.1.8; Dell X4012 Firmware 3.0.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21507 or the next vulnerability affects your stack