What’s Vulnerable › Vulnerabilities
CVE-2021-21515
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC SourceOne, versions 7.2SP10 and prior, contain a Stored Cross-Site Scripting vulnerability. A remote low privileged attacker may potentially exploit this vulnerability, to hijack user sessions or to trick a victim application user to unknowingly send arbitrary requests to the server.
Affected products
- Dell SourceOne: before 7.2; 7.2, 7.2-sp1, 7.2-sp2, 7.2-sp3, 7.2-sp4, 7.2-sp5 (+4) — fixed in 7.2
How to fix
Upgrade to a fixed version: Dell SourceOne 7.2. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000183430/dsa-2021-043-dell-emc-sourceone-java-script-xss-stored-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000183430/dsa-2021-043-dell-emc-sourceone-java-script-xss-stored-vulnerability
Get alerted when CVE-2021-21515 or the next vulnerability affects your stack