What’s Vulnerable › Vulnerabilities
CVE-2021-21522
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-28 · updated 2026-06-17
- Weakness: CWE-255
Description
Dell BIOS contains a Credentials Management issue. A local authenticated malicious user may potentially exploit this vulnerability to gain access to sensitive information on an NVMe storage by resetting the BIOS password on the system via the Manageability Interface.
Affected products
- Dell Latitude 5285 2-In-1 Firmware: before 1.13.0 — fixed in 1.13.0
- Dell Latitude 5289 2-In-1 Firmware: before 1.23.1 — fixed in 1.23.1
- Dell Latitude 5290 2-In-1 Firmware: before 1.16.0 — fixed in 1.16.0
- Dell Latitude 5310 2-In-1 Firmware: 1.7.0
- Dell Latitude 7210 2-In-1 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Latitude 7212 Rugged Extreme Tablet Firmware: before 1.33.0; 1.33.0 — fixed in 1.33.0
- Dell Latitude 7280 Firmware: before 1.21.1; 1.21.1 — fixed in 1.21.1
- Dell Latitude 7285 Firmware: before 1.11.0; 1.11.0 — fixed in 1.11.0
- Dell Latitude 7290 Firmware: before 1.20.0; 1.20.0 — fixed in 1.20.0
- Dell Latitude 7310 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Latitude 7370 Firmware: before 1.24.3; 1.24.3 — fixed in 1.24.3
- Dell Latitude 7380 Firmware: 1.21.1
- Dell Latitude 7389 Firmware: before 1.23.1 — fixed in 1.23.1
- Dell Latitude 7390 2-In-1 Firmware: before 1.19.0 — fixed in 1.19.0
- Dell Latitude 7390 Firmware: 1.20.0
- Dell Latitude 7410 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Latitude 7420 Firmware: before 1.7.1 — fixed in 1.7.1
- Dell Latitude 7480 Firmware: before 1.21.1 — fixed in 1.21.1
- Dell Latitude 7490 Firmware: before 1.20.1 — fixed in 1.20.1
- Dell Latitude 9410 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Latitude 9510 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Precision 3640 Tower Firmware: before 1.6.2 — fixed in 1.6.2
- Dell Precision 5510 Firmware: before 1.17.0 — fixed in 1.17.0
- Dell Precision 5520 Firmware: before 1.23.1 — fixed in 1.23.1
- Dell Precision 5530 2-In-1 Firmware: before 1.14.10 — fixed in 1.14.10
- Dell Xps 13 9360 Firmware: before 2.16.0 — fixed in 2.16.0
- Dell Xps 13 9370 Firmware: before 1.15.0 — fixed in 1.15.0
- Dell Xps 15 9575 2-In-1 Firmware: before 1.16.2 — fixed in 1.16.2
How to fix
Upgrade to a fixed version: Dell Latitude 5285 2-In-1 Firmware 1.13.0; Dell Latitude 5289 2-In-1 Firmware 1.23.1; Dell Latitude 5290 2-In-1 Firmware 1.16.0; Dell Latitude 7210 2-In-1 Firmware 1.7.0; Dell Latitude 7212 Rugged Extreme Tablet Firmware 1.33.0; Dell Latitude 7280 Firmware 1.21.1; Dell Latitude 7285 Firmware 1.11.0; Dell Latitude 7290 Firmware 1.20.0; Dell Latitude 7310 Firmware 1.7.0; Dell Latitude 7370 Firmware 1.24.3; Dell Latitude 7389 Firmware 1.23.1; Dell Latitude 7390 2-In-1 Firmware 1.19.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21522 or the next vulnerability affects your stack