What’s Vulnerable › Vulnerabilities
CVE-2021-21531
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-602
Description
Dell Unisphere for PowerMax versions prior to 9.2.1.6 contain an Authorization Bypass Vulnerability. A local authenticated malicious user with monitor role may exploit this vulnerability to perform unauthorized actions.
Affected products
- Dell Powermax Os: 5978
- Dell Solutions Enabler: before 9.1.0.15; from 9.2.0 before 9.2.1.6 — fixed in 9.1.0.15, 9.2.1.6
- Dell Solutions Enabler Virtual Appliance: before 9.1.0.15; from 9.2.0 before 9.2.1.1 — fixed in 9.1.0.15, 9.2.1.1
- Dell Unisphere for PowerMax: before 9.1.0.26; from 9.2.1.0 through 9.2.1.6 — fixed in 9.1.0.26
- Dell Unisphere for PowerMax Virtual Appliance: before 9.1.0.26; from 9.2.1.0 before 9.2.1.6 — fixed in 9.1.0.26, 9.2.1.6
How to fix
Upgrade to a fixed version: Dell Solutions Enabler 9.1.0.15, 9.2.1.6; Dell Solutions Enabler Virtual Appliance 9.1.0.15, 9.2.1.1; Dell Unisphere for PowerMax 9.1.0.26; Dell Unisphere for PowerMax Virtual Appliance 9.1.0.26, 9.2.1.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21531 or the next vulnerability affects your stack