What’s Vulnerable › Vulnerabilities
CVE-2021-21532
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-02 · updated 2026-06-17
- Weakness: CWE-16
Description
Dell Wyse ThinOS 8.6 MR9 contains remediation for an improper management server validation vulnerability that could be potentially exploited to redirect a client to an attacker-controlled management server, thus allowing the attacker to change the device configuration or certificate file.
Affected products
- Dell Wyse Proprietary OS (Modern ThinOS): before 8.6; 8.6 — fixed in 8.6
How to fix
Upgrade to a fixed version: Dell Wyse Proprietary OS (Modern ThinOS) 8.6. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000184665/dsa-2021-069-dell-wyse-thinos-8-6-security-update-for-an-improper-management-server-validation-vulnerabilitydsa-2021-069-dell-wyse-thinos-8-6-security-update-for-an-improper-management-server-validation-
- https://www.dell.com/support/kbdoc/en-us/000184665/dsa-2021-069-dell-wyse-thinos-8-6-security-update-for-an-improper-management-server-validation-vulnerabilitydsa-2021-069-dell-wyse-thinos-8-6-security-update-for-an-improper-management-server-validation-
Get alerted when CVE-2021-21532 or the next vulnerability affects your stack