What’s Vulnerable › Vulnerabilities
CVE-2021-21541
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC iDRAC9 versions prior to 4.40.00.00 contain a DOM-based cross-site scripting vulnerability. A remote unauthenticated attacker could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or JavaScript code to DOM environment in the browser. The malicious code is then executed by the web browser in the context of the vulnerable web application.
Affected products
- Dell EMC iDRAC: before 4.40.00.00 — fixed in 4.40.00.00
How to fix
Upgrade to a fixed version: Dell EMC iDRAC 4.40.00.00. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21541 or the next vulnerability affects your stack