What’s Vulnerable › Vulnerabilities
CVE-2021-21542
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC iDRAC9 versions prior to 4.40.10.00 contain multiple stored cross-site scripting vulnerabilities. A remote authenticated malicious user with high privileges could potentially exploit these vulnerabilities to store malicious HTML or JavaScript code through multiple affected while generating a certificate. When victim users access the submitted data through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable application.
Affected products
- Dell EMC iDRAC: before 4.40.00.00 — fixed in 4.40.00.00
How to fix
Upgrade to a fixed version: Dell EMC iDRAC 4.40.00.00. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21542 or the next vulnerability affects your stack