What’s Vulnerable › Vulnerabilities
CVE-2021-21545
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-427
Description
Dell Peripheral Manager 1.3.1 or greater contains remediation for a local privilege escalation vulnerability that could be potentially exploited to gain arbitrary code execution on the system with privileges of the system user.
Affected products
- Dell Peripheral Manager: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Dell Peripheral Manager 1.3.1. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000185100/dsa-2021-079-dell-client-security-update-for-dell-peripheral-manager-local-privilege-escalation-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000185100/dsa-2021-079-dell-client-security-update-for-dell-peripheral-manager-local-privilege-escalation-vulnerability
Get alerted when CVE-2021-21545 or the next vulnerability affects your stack