What’s Vulnerable › Vulnerabilities
CVE-2021-21547
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-312
Description
Dell EMC Unity, UnityVSA, and Unity XT versions prior to 5.0.7.0.5.008 contain a plain-text password storage vulnerability when the Dell Upgrade Readiness Utility is run on the system. The credentials of the Unisphere Administrator are stored in plain text. A local malicious user with high privileges may use the exposed password to gain access with the privileges of the compromised user.
Affected products
- Dell Unity: before 5.0.7.0.5.008 — fixed in 5.0.7.0.5.008
- Dell Unity Xt Operating Environment: before 5.0.7.0.5.008 — fixed in 5.0.7.0.5.008
- DELL EMC UnityVSA Operating Environment: before 5.0.7.0.5.008 — fixed in 5.0.7.0.5.008
How to fix
Upgrade to a fixed version: Dell Unity 5.0.7.0.5.008; Dell Unity Xt Operating Environment 5.0.7.0.5.008; DELL EMC UnityVSA Operating Environment 5.0.7.0.5.008. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21547 or the next vulnerability affects your stack