What’s Vulnerable › Vulnerabilities
CVE-2021-21577
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC iDRAC9 versions prior to 4.40.40.00 contain a DOM-based cross-site scripting vulnerability. A remote attacker could potentially exploit this vulnerability to run malicious HTML or JavaScript in a victim’s browser by tricking a victim in to following a specially crafted link.
Affected products
- Dell Emc Idrac9 Firmware: before 4.40.40.00 — fixed in 4.40.40.00
How to fix
Upgrade to a fixed version: Dell Emc Idrac9 Firmware 4.40.40.00. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21577 or the next vulnerability affects your stack