What’s Vulnerable › Vulnerabilities
CVE-2021-21595
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-77
Description
Dell EMC PowerScale OneFS versions 8.2.x - 9.1.1.x contain an improper neutralization of special elements used in an OS command. This vulnerability could allow the compadmin user to elevate privileges. This only impacts Smartlock WORM compliance mode clusters as a critical vulnerability and Dell recommends to update/upgrade at the earliest opportunity.
Affected products
- Dell Emc Powerscale Onefs: from 9.0.0.0 before 9.2.0; 8.2.2 — fixed in 9.2.0
How to fix
Upgrade to a fixed version: Dell Emc Powerscale Onefs 9.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-21595 or the next vulnerability affects your stack