What’s Vulnerable › Vulnerabilities
CVE-2021-21670
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-30 · updated 2026-06-17
Description
Jenkins 2.299 and earlier, LTS 2.289.1 and earlier allows users to cancel queue items and abort builds of jobs for which they have Item/Cancel permission even when they do not have Item/Read permission.
Affected products
- Jenkins: before 2.289.2; before 2.300 — fixed in 2.289.2, 2.300
How to fix
Upgrade to a fixed version: Jenkins 2.289.2, 2.300. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/06/30/1
- https://www.jenkins.io/security/advisory/2021-06-30/#SECURITY-2278
- http://www.openwall.com/lists/oss-security/2021/06/30/1
- https://www.jenkins.io/security/advisory/2021-06-30/#SECURITY-2278
Get alerted when CVE-2021-21670 or the next vulnerability affects your stack