What’s Vulnerable › Vulnerabilities
CVE-2021-21702: Null Dereference in SoapClient
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-15 · updated 2026-06-17
- Weakness: CWE-476
Description
In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.
Affected products
- Debian Linux: 9.0, 10.0
- Clustered Data ONTAP: all versions
- Oracle Corporation Communications Diameter Signaling Router (DSR): from 8.0.0 through 8.5.0
- PHP: from 7.3.0 before 7.3.27; from 7.4.0 before 7.4.15; from 8.0.0 before 8.0.2 — fixed in 7.3.27, 7.4.15, 8.0.2
How to fix
Upgrade to a fixed version: PHP 7.3.27, 7.4.15, 8.0.2. Check the vendor advisory for mitigations.
References
- https://bugs.php.net/bug.php?id=80672
- https://lists.debian.org/debian-lts-announce/2021/07/msg00008.html
- https://security.gentoo.org/glsa/202105-23
- https://security.netapp.com/advisory/ntap-20210312-0005/
- https://www.debian.org/security/2021/dsa-4856
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.tenable.com/security/tns-2021-14
- https://bugs.php.net/bug.php?id=80672
- https://lists.debian.org/debian-lts-announce/2021/07/msg00008.html
- https://security.gentoo.org/glsa/202105-23
- https://security.netapp.com/advisory/ntap-20210312-0005/
- https://www.debian.org/security/2021/dsa-4856
Get alerted when CVE-2021-21702 or the next vulnerability affects your stack