What’s Vulnerable › Vulnerabilities

CVE-2021-21703: PHP-FPM memory access in root process leading to privilege escalation

Description

In PHP versions 7.3.x up to and including 7.3.31, 7.4.x below 7.4.25 and 8.0.x below 8.0.12, when running PHP FPM SAPI with main FPM daemon process running as root and child worker processes running as lower-privileged users, it is possible for the child processes to access memory shared with the main process and write to it, modifying it in a way that would cause the root process to conduct invalid memory reads and writes, which can be used to escalate privileges from local unprivileged user to the root user.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.4.25, 8.0.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21703 or the next vulnerability affects your stack