What’s Vulnerable › Vulnerabilities

CVE-2021-21704: Multiple vulnerabilities in Firebird client extension

Description

In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using Firebird PDO driver extension, a malicious database server could cause crashes in various database functions, such as getAttribute(), execute(), fetch() and others by returning invalid response data that is not parsed correctly by the driver. This can result in crashes, denial of service or potentially memory corruption.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.3.29, 7.4.21, 8.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21704 or the next vulnerability affects your stack