What’s Vulnerable › Vulnerabilities

CVE-2021-21705: Incorrect URL validation in FILTER_VALIDATE_URL

Description

In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.3.29, 7.4.21, 8.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21705 or the next vulnerability affects your stack