What’s Vulnerable › Vulnerabilities

CVE-2021-21708: UAF due to php_filter_float() failing

Description

In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.4.28, 8.0.16, 8.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21708 or the next vulnerability affects your stack