What’s Vulnerable › Vulnerabilities
CVE-2021-21974
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 45.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-24 · updated 2026-06-17
- Weakness: CWE-787
Description
OpenSLP as used in ESXi (7.0 before ESXi70U1c-17325551, 6.7 before ESXi670-202102401-SG, 6.5 before ESXi650-202102101-SG) has a heap-overflow vulnerability. A malicious actor residing within the same network segment as ESXi who has access to port 427 may be able to trigger the heap-overflow issue in OpenSLP service resulting in remote code execution.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10.1.2; from 4.0 before 4.2 — fixed in 3.10.1.2, 4.2
- VMware ESXi: 6.5-2, 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101 (+222); 6.5, 6.7, 7.0.0
- VMware Cloud Foundation: 4.x before 4.2 and 3.x
- VMware ESXi: 7.0 before ESXi70U1c-17325551, 6.7 before ESXi670-202102401-SG, 6.5 before ESXi650-202102101-SG
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10.1.2, 4.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162957/VMware-ESXi-OpenSLP-Heap-Overflow.html
- https://www.vmware.com/security/advisories/VMSA-2021-0002.html
- https://www.zerodayinitiative.com/advisories/ZDI-21-250/
- http://packetstormsecurity.com/files/162957/VMware-ESXi-OpenSLP-Heap-Overflow.html
- https://www.vmware.com/security/advisories/VMSA-2021-0002.html
- https://www.zerodayinitiative.com/advisories/ZDI-21-250/
Get alerted when CVE-2021-21974 or the next vulnerability affects your stack