What’s Vulnerable › Vulnerabilities
CVE-2021-21985: VMware vCenter Server Improper Input Validation Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-26 · updated 2026-08-12
- Weakness: CWE-918
Description
The vSphere Client (HTML5) contains a remote code execution vulnerability due to lack of input validation in the Virtual SAN Health Check plug-in which is enabled by default in vCenter Server. A malicious actor with network access to port 443 may exploit this issue to execute commands with unrestricted privileges on the underlying operating system that hosts vCenter Server.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10.2.1; from 4.0 before 4.2.1 — fixed in 3.10.2.1, 4.2.1
- VMware vCenter Server: 6.5, 6.5-a, 6.5-b, 6.5-c, 6.5-d, 6.5-e (+45)
- VMware vCenter Server and VMware Cloud Foundation: VMware vCenter Server (7.x before 7.0 U2b, 6.7 before 6.7 U3n, 6.5 before 6.5 U3p) and VMware Cloud Foundation (4.x before 4.2.1, 3.x before 3.10.2.1)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10.2.1, 4.2.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162812/VMware-Security-Advisory-2021-0010.html
- http://packetstormsecurity.com/files/163487/VMware-vCenter-Server-Virtual-SAN-Health-Check-Remote-Code-Execution.html
- https://www.vmware.com/security/advisories/VMSA-2021-0010.html
- http://packetstormsecurity.com/files/162812/VMware-Security-Advisory-2021-0010.html
- http://packetstormsecurity.com/files/163487/VMware-vCenter-Server-Virtual-SAN-Health-Check-Remote-Code-Execution.html
- https://www.vmware.com/security/advisories/VMSA-2021-0010.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-21985
Get alerted when CVE-2021-21985 or the next vulnerability affects your stack