What’s Vulnerable › Vulnerabilities
CVE-2021-21990
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-11 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware Workspace one UEM console (2102 prior to 21.2.0.8, 2101 prior to 21.1.0.14, 2011 prior to 20.11.0.27, 2010 prior to 20.10.0.16,2008 prior to 20.8.0.28, 2007 prior to 20.7.0.14,2006 prior to 20.6.0.19, 2005 prior to 20.5.0.46, 2004 prior to 20.4.0.21, 2003 prior to 20.3.0.23, 2001 prior to 20.1.0.32, 1912 prior to 19.12.0.24) contain a cross-site scripting vulnerability. VMware Workspace ONE UEM console does not validate incoming requests during device enrollment after leading to rendering of unsanitized input on the user device in response.
Affected products
- VMware Workspace One Unified Endpoint Management: from 19.0.0.0 before 19.12.0.24; from 20.1.0.0 before 20.1.0.32; from 20.3.0.0 before 20.3.0.23; from 20.4.0.0 before 20.4.0.21; from 20.5.0.0 before 20.5.0.46; from 20.6.0.0 before 20.6.0.19 — fixed in 19.12.0.24, 20.1.0.32, 20.10.0.16, 20.11.0.27, 20.3.0.23, 20.4.0.21
- Vmware Workspace One UEM console: from VMware Workspace one UEM console (2102 prior through 21.2.0.8, 2101 prior to 21.1.0.14, 2011 prior to 20.11.0.27, 2010 prior to 20.10.0.16,2008 prior to 20.8.0.28, 2007 prior to 20.7.0.14,2006 prior to 20.6.0.19, 2005 prior to 20.5.0.46, 2004 prior to 20.4.0.21, 2003 prior to 20.3.0.23, 2001 prior to 20.1.0.32, 1912 prior to 19.12.0.24)
How to fix
Upgrade to a fixed version: VMware Workspace One Unified Endpoint Management 19.12.0.24, 20.1.0.32, 20.10.0.16, 20.11.0.27. Check the vendor advisory for mitigations.
References
- https://herolab.usd.de/security-advisories/usd-2021-0008/
- https://www.vmware.com/security/advisories/VMSA-2021-0008.html
- https://herolab.usd.de/security-advisories/usd-2021-0008/
- https://www.vmware.com/security/advisories/VMSA-2021-0008.html
Get alerted when CVE-2021-21990 or the next vulnerability affects your stack