What’s Vulnerable › Vulnerabilities
CVE-2021-21991
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-22 · updated 2026-06-17
Description
The vCenter Server contains a local privilege escalation vulnerability due to the way it handles session tokens. A malicious actor with non-administrative user access on vCenter Server host may exploit this issue to escalate privileges to Administrator on the vSphere Client (HTML5) or vCenter Server vSphere Web Client (FLEX/Flash).
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10.2.2; from 4.0 before 4.3 — fixed in 3.10.2.2, 4.3
- VMware vCenter Server: 6.5, 6.5-a, 6.5-b, 6.5-c, 6.5-d, 6.5-e (+48)
- VMware vCenter Server, VMware Cloud Foundation: VMware vCenter Server(7.x before 7.0 U2c, 6.7 before 6.7 U3o and 6.5 before 6.5 U3q) and VMware Cloud Foundation (4.x before 4.3 and 3.x before 3.10.2.2)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10.2.2, 4.3. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
Get alerted when CVE-2021-21991 or the next vulnerability affects your stack